Guide To Compiling The Source Code

A place to show off your mods and discuss modding SCPCB.
User avatar
MonocleBios
MTF
Posts: 615
Joined: Tue Dec 18, 2012 5:22 am
Location: The Great White North

Re: Guide To Compiling The Source Code

Postby MonocleBios » Sun Dec 30, 2012 9:54 pm

Glitch wrote:
MonocleBios wrote:Is 'FastExt.bb' in the same directory as 'Main.bb'?


Eeyup

What version of blitz3D do you have?
Put an invalid statement in fastext.bb, does another error show up?
M-x dingus-mode

User avatar
Glitch
Moderator
Posts: 4119
Joined: Fri Nov 02, 2012 8:03 pm
Location: [REDACTED], England

Re: Guide To Compiling The Source Code

Postby Glitch » Sun Dec 30, 2012 10:32 pm

It doesn't give me a version number, closest thing I have is the date modified which is 10/08/2011 (DD/MM/YYYY)

How do I create an invalid statement? I'm a bit of a derp with these.
I'm not here as much right now, mention me on our Discord server if you need anything.

User avatar
MonocleBios
MTF
Posts: 615
Joined: Tue Dec 18, 2012 5:22 am
Location: The Great White North

Re: Guide To Compiling The Source Code

Postby MonocleBios » Sun Dec 30, 2012 11:24 pm

Glitch wrote:It doesn't give me a version number, closest thing I have is the date modified which is 10/08/2011 (DD/MM/YYYY)

How do I create an invalid statement? I'm a bit of a derp with these.

Add something to the beginning of the file that would cause a compiler error, like the line 'ermagherd 5'
M-x dingus-mode

User avatar
Glitch
Moderator
Posts: 4119
Joined: Fri Nov 02, 2012 8:03 pm
Location: [REDACTED], England

Re: Guide To Compiling The Source Code

Postby Glitch » Sun Dec 30, 2012 11:26 pm

Did that, got a function not found error message and my invalid statement was highlighted.
Thanks for helping me with this btw.
I'm not here as much right now, mention me on our Discord server if you need anything.

User avatar
MonocleBios
MTF
Posts: 615
Joined: Tue Dec 18, 2012 5:22 am
Location: The Great White North

Re: Guide To Compiling The Source Code

Postby MonocleBios » Mon Dec 31, 2012 1:46 am

Glitch wrote:Did that, got a function not found error message and my invalid statement was highlighted.
Thanks for helping me with this btw.


I'm assuming you also added the decl/dll to Blitz' userlibs directory and restarted Blitz3D.
Can you post a screenshot of the original error?
M-x dingus-mode

User avatar
Glitch
Moderator
Posts: 4119
Joined: Fri Nov 02, 2012 8:03 pm
Location: [REDACTED], England

Re: Guide To Compiling The Source Code

Postby Glitch » Mon Dec 31, 2012 1:50 am

I didn't see a userlibs folder so I created my own in the same directory as blitz3d, I will get an image of the error tomorrow because its like 1:50 and I'm in bed.
I'm not here as much right now, mention me on our Discord server if you need anything.

User avatar
MonocleBios
MTF
Posts: 615
Joined: Tue Dec 18, 2012 5:22 am
Location: The Great White North

Re: Guide To Compiling The Source Code

Postby MonocleBios » Mon Dec 31, 2012 2:07 am

Glitch wrote:I didn't see a userlibs folder

I think that might be your problem there. Have you tried getting a newer version of Blitz3D?
M-x dingus-mode

User avatar
Glitch
Moderator
Posts: 4119
Joined: Fri Nov 02, 2012 8:03 pm
Location: [REDACTED], England

Re: Guide To Compiling The Source Code

Postby Glitch » Mon Dec 31, 2012 12:50 pm

MonocleBios wrote:
Glitch wrote:I didn't see a userlibs folder

I think that might be your problem there. Have you tried getting a newer version of Blitz3D?

I'll look.
I'm not here as much right now, mention me on our Discord server if you need anything.

User avatar
InnocentSam
MTF
Posts: 958
Joined: Wed Dec 19, 2012 4:09 pm
Location: Gallowmere
Contact:

Re: Guide To Compiling The Source Code

Postby InnocentSam » Mon Dec 31, 2012 12:53 pm

I tried disabling the launcher, but it keeps throwing "Memory access violation" errors on startup. Anyone else had this problem and knows how to fix?

User avatar
Glitch
Moderator
Posts: 4119
Joined: Fri Nov 02, 2012 8:03 pm
Location: [REDACTED], England

Re: Guide To Compiling The Source Code

Postby Glitch » Mon Dec 31, 2012 2:50 pm

I appear to be getting the same problem, first time I compile the source code it worked, only the program closed straight after being opened. I tried compiling again and got an error saying "function 'initext' not found".
I got the 1.98 update and put the fastext.dll in the userlibs folder, anything else I could be doing wrong?
I'm not here as much right now, mention me on our Discord server if you need anything.


Return to “Modding”

Who is online

Users browsing this forum: No registered users and 3 guests