Page 2 of 2

Re: [REL] USS Cubera (0.7.0.1)

Posted: Sat Jan 13, 2018 5:44 am
by HalfdeadKiller
Updated Submarine. Added sonar to the helm, and some bug fixes. Also trying a different wiring system for the automatic doors in the lower section.

Re: (0.7.0.1) [REL] USS Cubera (Barotrauma Extended)

Posted: Thu Jan 18, 2018 9:01 pm
by LandonGam3r
Thank you for updating it once more! Latest version is now running at the server. I have shortly tested it and the terminals are working again.

Re: (0.7.0.1) [REL] USS Cubera (Barotrauma Extended)

Posted: Sat Jan 27, 2018 4:57 pm
by rico6822
What about defending lower and upper part of the ship?

Both are large and no railguns reaches them.

Are you sure nothing very often will be attacking submarine from those sides?

Re: (0.7.0.1) [REL] USS Cubera (Barotrauma Extended)

Posted: Mon Jan 29, 2018 11:48 pm
by HalfdeadKiller
Oh things will often attack the upper and lower part of the submarines. It is up to the pilot to make sure that doesn't happen.

Re: (0.7.0.1) [REL] USS Cubera (Barotrauma Extended)

Posted: Sun Mar 25, 2018 11:16 pm
by LandonGam3r
Hey HalfdeadKiller,

Due to the current version of Barotrauma having a bug that causes problems to some submarines, mainly affecting the grid, I did a check through the list of subs currently in rotation at our server(s). It turned out that the USS Cubera IX has a problem at the moment:

USS Cubera IX - several fires on start, relays breaking.

The submarine has been temporary removed from the list, till a new game update fixes this problem.

Re: (0.7.0.1) [REL] USS Cubera (Barotrauma Extended)

Posted: Tue Apr 03, 2018 2:50 am
by HalfdeadKiller
It's probably because the ship hasn't been saved in the new barotrauma version. I'll take a look at it hopefully soon, been busy with work.

Edit 1: Saving and launching does not seem to fix the issue. The power is behaving weird. It seems like each relay/junction box is receiving only local loads, and not shipwide loads. Thus there is too much power and not enough load, and the box/relay blows up. Unknown if I can fix this via the submarine editor.

Edit 2: Oh. Oh god. It appears replacing the junction boxes/relays, and rewiring them fixes the issue. You'd have to rewire the entire ship. My guess is that the junction boxes and relays have old code in them when loaded, and the game doesn't like loading old saved items with new game code. Though what's interesting is that the default submarines don't seem to suffer from the same issue. So either they were rewired for the new version, or something else is fucky. More testing is needed before I spend a few days replacing and rewiring everything. That took legit a week or so to do on this submarine.

Re: (0.7.0.1) [REL] USS Cubera (Barotrauma Extended)

Posted: Tue Apr 10, 2018 12:56 pm
by LandonGam3r
:shock2: That's indeed a lot of work. Glad you are checking it though, no rush needed, I have the sub noted for checking and whenever a new update lands (that possibly fixes this problem), I can bring the existing version back at the server.

Re: (0.7.0.1) [REL] USS Cubera (Barotrauma Extended)

Posted: Wed Jul 11, 2018 5:43 pm
by nerd
I've encountered problems with the X and IX version. Engine and battery junction boxes (I think the aft batteries, not sure) break or catch on fire. Is there any way to fix this?