Game/Launcher doesn't start (Not Responding)

NOTE: All the links in the Quick Guidelines 404s, so I'm not sure if this is a common issue but I've googled for a few hours already and my google-fu failed me.

Just downloaded v1.3.11 in my Windows 10 64bit, ran the game as admin and this happens:
A small window opens in my desktop with black background at "Not Responding" immediately and nothing else happens, no errors or anything.

What I've already done:
  • Restarted the PC,
  • "Turned on" DirectPlay as a Windows Feature and restarted the PC,
  • Disabled Windows Real-Time Protection (just in case),
  • Ran in Compatibility Mode for 8, 7, Vista and XP,
  • Unzipped directly into C and tried from there,
  • Same as above, in all compatibility modes,
  • Tweaked options*, no change whatsoever,
  • Tried downloading v1.2.14** instead, same thing happens,
  • Tried downloading v1.1** instead, same thing happens,
  • Tried downloading v0.6.5** instead, same thing happens.

Guessing this engine doesn't like my setup at all, but I see people running it fine in Win10, any solutions?

* Tried the following options in options.ini, since the launcher doesn't seem to open at all:
        - Setting height and width to my resolution
        - Tried different variations of Fullscreen/Borderless
        - Tried different numbers in gfx driver (Default: 2)
        - Tried enabling vram
        - Check for updates = false
        - Play startup video = false
        - Launcher enabled = false

** Downloaded previous versions from: viewtopic.php?t=7315

EDIT 1: Now trying to compile the game from source to see if it works, I installed Blitz 3D v1.108, replaced bin with mavless_bin contents, put every .dll/.decls in userlibs, getting the error "Unable to open include file", after some quick googling, this post lets me know I need, I can find but not either of the other ones as the original website has also 404'd.

EDIT 2: Okay, regardless of my failure to compile SCP; successfully compiling the Blitz 3D Games that come with the engine results in the same exact thing happening when running, a window of the same size, with black background, immediately set to "Not Responding". Even more obviously now, the engine doesn't like my setup. Turning Google-fu attention to Blitz3D.

EDIT 3: Updated GPU Drivers, not that this is a particularly helpful tip for running old games, should probably be reverting if anything - but a different driver at all might've fixed the problem if I believed enough! Nothing helpful from the Blitz3D Google-fu so far, trying a different system.

EDIT 4: It works in a different system effortlessly that I installed the same exact way with the same OS (Windows 10 64bit) and uses the same GPU (GTX 1650) with the same updated drivers. Still would like clues into how to make it work in my system without a full reformat, since the other PC isn't mine. I'm gonna disable a bunch of Windows crap from Performance options and turn off unnecessary services and apps and try again, if it doesn't work, I'll try Safe mode.

EDIT 5: Nothing I changed in Windows works (disable everything in Performance, get rid of non-windows services and running apps). Safe Mode doesn't work either, after both attempts the problem is the exact same as originally described. Ran out of ideas, I'm stumped.

EDIT 6: Decided to try a Windows XP VM to run this game on, as I've had previous success running games smoothly in XP with VMWare, as the OS is pretty light. Installed .NET Framework, installed 2008 Redist, currently getting "The procedure entry point _except_handler4_common could not be located in the dynamic link library msvcrt.dll". Figure this is an outdated dll then, can't find an update for it in XP - so I'm unsure this game supports XP? Either way, figure if that's broken, probably a lot else is, I guess I need to upgrade the VM to Windows 7... though that's a whole other level of system resources.

EDIT 7: Works fine and "out of the box" in Windows 7 VM, but can't get it to run smoothly, of course, without dedicating a GPU for it. Sticking my host machine into the onboard graphics and using the nVidia GPU as the dedicated card for the virtualization solves the problem, but it's... terribly inconvenient. Oh well, I give up, post stays because I couldn't find this same problem while browsing and maybe someone will and have some other ideas.
Last edited by Laenar on Tue Nov 05, 2019 11:27 pm, edited 3 times in total.