Dealing with Memory Access Violations

Just a note: This thread is specifically tailored towards assisting people who encounter an MAV when they launch the game. It's likely that crashes which happen mid-session will not be fixed by any of the suggestions on this thread.

In addition, this thread is not a support desk, and should not be treated as such. Please do not post bug reports on this thread. You should instead create a new thread in the bug reports forum detailing your problem. Always remember to provide as much information as possible when writing bug reports!

What is a Memory Access Violation?

For the most part, a Memory Access Violation (or MAV for short) is an error which often occurs when the game fails to load an asset due to either a coding bug or something else on your PC which is interfering with the game's ability to read assets from its folders.


How do I get rid of a Memory Access Violation?

Resolving an MAV is tricky, mainly because why, where, and when they happen can vary with each version and computer. This thread is gonna focus primarily on MAVs which occur the second the game boots up, but some of these solutions may also work for in-game ones.

MAVs which occur upon simply opening the game are usually a problem on your end rather than a problem with the game itself (usually). After searching through several threads on both the CB and Blitz forums regarding this topic, I've created a list of possible fixes. I cannot guarantee though that these will get rid of the MAV altogether. As I said before, the reasons for them occurring can vary.

Anyway, here's the list:
  • Right click the .exe file, select 'Run as Administrator'.
  • Right click the game's folder, select 'Properties', untick 'Read Only', click Apply, then try running it.
  • Right click on the .exe, select 'Properties', go to the 'Compatibility' tab, set compatibility to XP Service Pack 3.
  • Disable the UAC (User Account Controls).
  • Disable visual themes.
  • Disable desktop composition.
  • Disable display scaling on high DPI settings.
  • Kill "taskhost.exe" process in your task manager.
  • Occasionally your download may just be corrupted, try re-downloading the game and see if you encounter the same bug.
    • The same thing can also happen to save files, try starting a new game with the same seed to see if you encounter the same bug at the same moment. If you don't then the save is most likely corrupted.
  • On Windows 7/8 your Data Execution Prevention may think that the game is a harmful program and thus prevent it from running correctly. To disable the DEP open the Cmd.exe as an administrator and paste this:

    Code: Select all

    bcdedit.exe /set {current} nx AlwaysOff
    Restart your computer then try running the game.

    If you want to turn the DEP back on then re-open the Cmd.exe and paste this:

    Code: Select all

    bcdedit.exe /set {current} nx AlwaysOn
Also apparently third-party technology (such as tablets) can interfere with the game's ability to run. I can't really help there, but here's a post from someone who figured out that it was his tablet preventing the game from running:
DrShikura wrote:EUREKA! I got it figured out! The problem WAS interference with Third-Perty technology UNRELATED to Blitz3D altogether. The problem is Wacom Tablets! If you are experiencing this issue, then chances are, you are using a Wacom™ Drawing Tablet. This tablet is interfering with your game's launching mechanisms. An easy fix for this:

Right click the SCP - Containment Breach EXE
Run in Compatibility Mode
Launch as Administrator
Click Apply
Click OK

Press Ctrl + Shift + Escape to open the task manager.
Go to the PROCESSES tab.
Find the following processes and KILL them!

wisptis.exe (This one will rebuild. It's fine.)

At this point, the problem should be SOLVED! Good luck everyone!

I've tried everything above and it still won't run!

Well then at this point there's two possible reasons as to why you're encountering an MAV. Your computer is incapable of playing any Blitz Max/3D/Plus games or it's a bug with the game itself.

First off, let's test to see if it's just a problem with every Blitz3D game. Try downloading and running this executable made by MonocleBios:

If you still get an MAV, then it means that something on your computer is interfering with its ability to run B3D games. At this point you should just troubleshoot on the Blitz3D forums.
Last edited by CommanderMark on Tue May 29, 2018 3:27 pm, edited 26 times in total.

Re: Dealing with Memory Access Violations

Another tip that could work (I read it somewhere in the past) is to disable the launcher if the game crashes after clicking "launch". Better explanation:

- open the launcher
- disable "Use launcher"
- click on "Launch"
- the MAV pops up
- restart the game
- the launcher is now being skipped and the MAV shouldn't occur anymore

(That may not work for everyone)
Do you think NASA invented thunderstorms to cover up the sound of space battles?

Re: Dealing with Memory Access Violations

The game works fine and crashes don't really occur until I abuse the cheats console. However, if I try to open it using a shortcut or steam instead of going to winrar to run the .exe I get the MAV. When I witched it to XP pack 3 and run as admin I get a different error:"user lib not found"(I will just call it an ULNF) did I screw it up even more? This has also been ocurring when I try to run the Box of horrors mod by itself even though I followed the instructions (except I do not get MAVs just ULNFs) please help me so I can enjoy my game and perhaps play mods. :035:

Re: Dealing with Memory Access Violations

zains17 wrote:I keep getting the Memory Access Violations only when it ride the elevator to the basement. Does anyone know anything about this?
Also, I thought it might of been a corrupt download, but I'v downloaded it many times and it's still not working.
I assume that leads to SCP-939? If so yeah other people have been having problems with it too (and me as well, once). Hope this gets fixed.
Hoyt_Ridge wrote:I've tried everything, but nothing works for me, but... Disabling of bump-mapping helped me in a moment.
Are you using the 1.0.3 patch? Because I'm pretty sure that problem with bump mapping enabled is fixed now. Unless it's a new bug...
SCP: Eric Breach nanomod maker (if anyone wants to revamp it be my guest, as it is now defunct)
Fan of Doctor Who, Dirk Gently's Holistic Detective Agency, Sleepy Hollow, Person of Interest, Happy (2017) and Silicon Valley. And also MCU films.