[1.0.4] Large Testing Chamber MAV

#1
I've notice that every time I enter the bottom floor of the large testing chamber to get the SCP-682 document, I get an MAV just as the decontamination gas starts to pour down, and SCP-079 says "You're not getting out." So I've done a little homework and this is what I gathered:

First off, computer specs:
Computer: HP Pavilion dv6 Notebook PC 64-bit
OS: Windows 7
Processor: Intel Core2 Duo CPU T6600; 2.20GHz
Installed RAM: 4.00 GB
Graphics: Mobile Intel 4 Express Chipset Family

What happens:
MAV in large testing chamber bottom floor at the same time the decontamination gas starts to pour down, and SCP-079 says "You're not getting out."

When it happens:
1) I tried testing the bug on 3 different map seeds with Windows XP SP3 compatibility, running as Administrator, bump mapping off, and windowed screen (presumed independent on map seeds). I arrived to the testroom each time without the use of the teleport function in the console.
2) Redownloaded the SCPv1.0.4 executable 3 times and starting over again (deleted save files), keeping settings, window, compatibility, and administration privileges constant. Still happened.
3) Keeping settings, window, compatibility, and administration privileges constant, I tried immediately teleporting directly to the room on three different mapseeds using the "teleport testroom" command after disabling intro sequence to see if any prior events made the file corrupt. Still happened. I then did the same thing with the intro sequence enable, and teleported after the "Press F5 button to save" text appeared on the screen after 173 broke out of containment. Still happened.
4) Still keeping everything constant, I tried 1) and 3) in full screen mode. Still happened.
5) I tried unchecking the compatibility box for Windows XP SP3, running as Administrator, and bump mapping off. I tried 1) and 3) with fullscreen and windowed. All cases still had an MAV.
6) I ran it with Windows XP SP3 compatibility, running as Administrator, and bump mapping on. I tried 1) and 3) with fullscreen and windowed. All cases still had an MAV.
7) Lastly, I tried running with Windows XP SP3 compatibility, bump mapping on, and not running as Administrator in both windowed and fullscreen. 1) and 3) still had an MAV.

Special Note:
I noticed some posts on wireframe toggling on the forum page, so I tried that this morning. I turned on the wireframe, and noticed a red line that traverses through the facility on the floor. I assume that this means that wherever the line is is where the player can go. Just a hunch (not a game designer). I followed the red line down the stairs of the large testing chamber down to the bottom floor and I noticed that the red line terminates right before the MAV happens, like immediately right before. I wonder if this red line termination is indicating that the game is bugged in that area beyond the red line termination.

I also want to mention that I used the debughud in each test case. I compared the debughud in the testroom on the 1.0.4 version and 1.0.3 version. This is what I gathered:

Version 1.0.3, before the 079 event:
Room: testroom
Room event: testroom
state: 0.0
state2: 0.0
state3 0.0

Version 1.0.3, after the 079 event:
Room: testroom




Version 1.0.4, before the 079 event:
Room: testroom
Room event: testroom
state: 1.0
state2: 0.0
state3 0.0

Version 1.0.4, after the 079 event:
(N/A because of MAV)

It's the fact that in version 1.0.4 the value of state(1) has a value of 1.0 versus the 1.0.3 version that has a state(1) value of 0.0 is what concerns me. It might mean nothing, idk.


My current mapseed that I made the most progress on is: 1jd1ogr

Thank you guys so much. I am a really huge fan of this game, and praise all the work that you guys have done to make it. :)

Re: [1.0.4] Large Testing Chamber MAV

#5
I pretty much signed up to report this bug. I am also using Windows 7 64-bit and 1.0.4 (will test previous versions.)

Do you also happen to get a MAV when you try to open the door that has a DNA scanner without using an item on it too? There is one in the upper section of the Large Testing Chamber if you don't already know.

EDIT: I also use the compability modes and all the other listed MAV work-arounds.
Where else was there a DNA scanner? Was it outside the elevator that leads to SCP-049?
Last edited by Almaeges on Thu Aug 14, 2014 3:18 pm, edited 2 times in total.

Re: [1.0.4] Large Testing Chamber MAV

#6
Almaeges wrote:I pretty much signed up to report this bug. I am also using Windows 7 64-bit and 1.0.4 (will test previous versions.)

Do you also happen to get a MAV when you try to open the door that has a DNA scanner without using an item on it too? There is one in the upper section of the Large Testing Chamber if you don't already know.

I noticed this problem too.
Here's what I've done to test it:

Initial Conditions:
- downloaded a new copy of SCPv1.0.4 using MEGA
- only used one map seed (ozn9pu) for this test.
- disabled intro sequence
- teleported to large testing chamber and walked up the stairs to the DNA Scanner door once SCP 682 finished shaking the building in the intro (I deemed the end of the intro)
- saved the game with F5 to make a reference file


The following tests were done by simply walking up to the door and clicking the DNA scanner.

Initial test (0):
not running on admin, no compatibility mode, no bump mapping, windowed, graphics: mobile Intel 4 Series -> MAV

Test 1
running on admin, no compatibility mode, no bump mapping, windowed, graphics: mobile Intel 4 Series -> MAV

Test 2
running on admin, compatibility mode Windows XP SP3, no bump mapping, windowed, graphics: mobile Intel 4 Series -> MAV

Test 3
running on admin, compatibility mode Windows XP SP3, bump mapping, windowed, graphics: mobile Intel 4 Series -> MAV

Test 4
running on admin, compatibility mode Windows XP SP3, bump mapping, fullscreen, graphics: mobile Intel 4 Series -> MAV

Test 5
running on admin, compatibility mode Windows XP SP3, bump mapping, fullscreen, graphics: primary display driver -> MAV


I ran the same tests (0-5) after I used the console to "spawn item severed hand", picked up the hand, verified that it was in my inventory, and saved using F5.

Result: Test (0-5) still had MAV (not using the severed hand from my inventory).

I hope this helps the investigation. I wonder if the large test chamber is bugged itself because the DNA scanner is giving me the same problems I had when testing my above mentioned bug.

Re: [1.0.4] Large Testing Chamber MAV

#7
Almaeges wrote:Where else was there a DNA scanner? Was it outside the elevator that leads to SCP-049?
That's a little bit off topic from this thread, but yes, the DNA scanner is also found outside each (2) elevator that goes down to SCP-049, and they have a similar (I haven't yet compared with large testing chamber DNA scanner MAV) issue.

Re: [1.0.4] Large Testing Chamber MAV

#8
Thank you for the detailed bug report! Like Monoclebios said it really is a breath of fresh air to see useful reports that are descriptive and contain meaningful steps that can be used to recreate the issue. I threw together a fix for the DNA scanner and the 079 message MAVs described above, but I don't have access to the internet outside my phone right now so I'll have to upload it when I get home.

EDIT: Monocle I meant to ask, do you know of any way to perform the And operation with short circuiting? I noticed short circuiting does not occur in Blitz and the AndAlso operation isn't recognized. I couldnt separate it into several if statements either or else statements would not have worked properly.

Re: [1.0.4] Large Testing Chamber MAV

#9
risingstar64 wrote:Thank you for the detailed bug report! Like Monoclebios said it really is a breath of fresh air to see useful reports that are descriptive and contain meaningful steps that can be used to recreate the issue. I threw together a fix for the DNA scanner and the 079 message MAVs described above, but I don't have access to the internet outside my phone right now so I'll have to upload it when I get home.

Awesome! Thank you risingstar!! I noticed that other new bug reports started to get more thorough after I posted mine. :laugh: Hopefully it becomes a trend.

I'll do my best to give you guys as much detail as I can for future bugs.

Re: [1.0.4] Large Testing Chamber MAV

#10
I just got back and added my fixes to my compilation thread
http://scpcbgame.com/forum/viewtopic.ph ... 081#p87081
you can download the file directly here
http://www.mediafire.com/download/m0u93 ... gfixes.zip
Please let me know if this fixes the issues addressed in this thread. I made a few small changes to the testroom code in addition to addressing the MAV, so I'm not entirely certain that the room still functions as intended / doesn't crash.